Text

Recognition Thread cannot be started

I have a Recognition Thread cannot be started error. I've created an app in Online User Admin, and subsequently created a certificate using my apps bundle identifier. I downloaded the .h file and copied it to my apps development folder and renamed it as MyCertificate.h. When I debug the app on a iPad simulator, the Recognition Thread has not been started.
If I now go to Console in Online User Admin, I don't see the name of my app only ATKSamples is listed, and therefore I'm unable to see the reason for my problem.
Any Ideas?


Thanks for your bug report,
I have checked our atk server and I can see you have created 2 applications:
-com.whicht
-com.whichtoolface.HeadStartSpelling
Do you face the issue in both applications? Could you please make sure the bundle Identifier is properly settings in the build settings (Case sensitive!)?
Otherwise, are you able to run the default sample?
In order to check what happens, could you please let us know more details:
- XCode version
- device model/simulator
Best regards

That's the thing also, I've downloaded MyCertificate.h for the iOS ATKSamples, initially the ITC sample worked, but now doesn't start Recognition thread as well. But as you'll see from the console, I hadn't followed the online instructions for setting up a new App, and was using the MyCertificate.h for my new app. However, I think I followed instructions correctly, however get the Recognition Thread not started warning in my new app.
I'm using Xcode 7.2.1 and building for iOS 9.2. Bundle Identifier is com.whichtoolface.HeadStartSpelling
I'd like to get on top of this, as this your software is really the fundamentals of my Spelling app for Primary Kids.
thanks

Just noticed after downloading MyScript_ATK-ios-1.3.0 again and the MyCertificate.h associated, I get all the samples to the Recognition thread is started except InteractiveTextComponentSample.

Thanks for all those details and testing.
About ITC, could you please make sure you have uninstalled the previous version on the device before a new fresh install and enable Internet connection as well?
Regarding the logs about your application, there is still a mismatch error between bundle identifier set in the build settings of your app and set on the atk server.
Could you please try again to set com.whichtoolface.headstartspelling in your app and create a new certificate on the atk server side with the same string for bundle identifier value (not in the description that is not mandatory)? download the new certificate and try again.
Thanks for your patience.

No, I tried that, renamed bundle identifier in my app to lower case, and created a new certificate, disabled the previous certificate. Same Recognition thread not started error.
Strange that InteractiveTextComponentSample shows Recognition thread not started error, yet all other examples work perfectly. Perhaps nothing todo with MyCertificate.h?
I'll probably have to persevere with tesseract, which is sad as would like to recognise joined up writing.
Thanks for your help.

Dear Sir,
We have been investigating and have finally made a change in our server database that should solve the problem. Every sample should be working properly if they have an internet connection.
Please accept our sincere apologies for any inconvenience caused.
Best regards

You beauty, thanks....I'm up and running

Thanks for your feedback and your understanding.
Best regards

Login or Signup to post a comment