Application Tool Kit

My certificate is not valid with Geometry Widget but MathScript works.

I have integrated MyScript with Math && Geometry to my swift project. Math script works very well. But Geometry doesn't work because of certificate. It's really strange that validation of certificate is valid for Math only. So cannot continue to next step. Sometime it show message "Cannot register certificate (NO_SUCH_FILE)". I also   create sample project with Objective-C by using that certificate then follow your instruction. Unlucky my certificate's still invalid. I don't know why. I spent many hours to search that issue in your forum but didn't solve yet. 

Dear Sovannarith Sok,

thank you for contacting us.

Currently, I checked your certificate and I confirm it contains the Geometry widget.

It rather looks you are facing other issues, such as ATKCore.framework not properly linked in your project, or geometry view not declared in your story board:

Can you please check this, and let us know if this doesn't help?

Best regards,


Thanks Oliver,  I have checked ATKCore.framework is the last linking in Build Settings of my project. I also have try declaring with Storyboard and non-Storyboard but no luck. As I told you before MathScript is working why it's not.  I used only 1 certificate. By the ways, I have tried Single Line and Single Character widget it also works with that certificate. I really don't understand. 

This is log: 

2017-06-23 15:26:14.117 Geometry[18756:192195] Cannot apply color sub style if widget isn't configured

2017-06-23 15:26:14.117 Geometry[18756:192195] Cannot apply thickness sub style if widget isn't configured

2017-06-23 15:26:14.158 Geometry[18756:192195] Cannot register certificate (NO_SUCH_FILE)

Dear Sovannarith,

Did you check Geometry View exists in your StoryBoard and has the 'reference outlet' to the View Controller? Please visit Apple Developer website for more details:

See also the following topic (last post):

If this doesn't help, could you please provide us with your project, so that we can investigate further?

Best regards,


Hi Oliver, you can download and check with my example shape  project here. 



Dear Sovannarith,

thank you for the project, which helped us understand the problem.

Currently, it is not related to the certificate but to the "styles.css" file that can not be found.

Here is the way you should proceed:
-In your xcode project, delete the "styles.css" file
-Encure to remove the reference when asked for
-Go in your file explorer, and look for the "css" directory
-Select the "css" directory and drop it into your xcode project =>ensure you create the folder references
-The css directory should appear in your xcode project
-Run your poject, it should appear as "configured" in the console log

Let us know if this works.

Best regards,


Thanks for helping. It works now.