Text

[myscript text web] guide is not hiding.

I have implemented myscript in one for my project. Its working perfect. I just have small issue. I am following below link for configuration.

https://developer.myscript.com/docs/interactive-ink/1.2/web/reference/configuration-myscriptjs/

I want to disable guide/smart guide. Below is my code. Guide is still visible. How can I disable it?


MyScriptJS.register(this.domEditor.nativeElement, {

      recognitionParams: {

        type: 'TEXT',

        protocol: 'WEBSOCKET',

        apiVersion: 'V4',

        server: {

          scheme: 'https',

          host: 'webdemoapi.myscript.com',

          applicationKey: 'XXXXX,

          hmacKey: 'XXXXX',

        }

      },

      text: {

        guides: {

          enable: false

        },

        smartGuide: false

      }

    });


Hello,


Thank you for your question.

When using MyScriptJS or web-components the prefix "recognitionParams.v4" should be added if the apiVersion is set to V4.

So in your case your configuration should look like this :


MyScriptJS.register(this.domEditor.nativeElement, {
      recognitionParams: {
        type: 'TEXT',
        protocol: 'WEBSOCKET',
        apiVersion: 'V4',
        server: {
          scheme: 'https',
          host: 'webdemoapi.myscript.com',
          applicationKey: 'XXXXX',
          hmacKey: 'XXXXX',
        }
      },
      v4: {
        text: {
          guides: {
            enable: false
          },
          smartGuide: false
        }
      }
    });


Regards,


Maël

Tried this. Not working. :( Any other help?

Hello,


Indeed, all the configuration parameters should be under "recognitionParams":


MyScriptJS.register(this.domEditor.nativeElement, {
    recognitionParams: {
        type: 'TEXT',
        protocol: 'WEBSOCKET',
        apiVersion: 'V4',
        server: {
            scheme: 'https',
            host: 'webdemoapi.myscript.com',
            applicationKey: 'XXXXX',
            hmacKey: 'XXXXX',
        },
        v4: {
            text: {
              guides: {
                enable: false
              },
              smartGuide: false
            }
        }
    }
});


Let me know is this is usefull.


Regards,


Maël

It worked thanks!