Text

Crashes in android Nougat OS

Dear Team,

We are able to integrate your SDK for handwriting recognition, and it's working great in the Android app except for "Naugat OS". We are getting crashes with below crash log:


====================================

D/AndroidRuntime: Shutting down VM

E/AndroidRuntime: FATAL EXCEPTION: main

    Process: com.fluidtouch.noteshelf, PID: 9608

    java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "_Unwind_Resume" referenced by "/data/app/com.fluidtouch.<myapp>/lib/x86_64/libiink.so"...

        at java.lang.Runtime.loadLibrary0(Runtime.java:989)

        at java.lang.System.loadLibrary(System.java:1530)

        at com.myscript.iink.NativeLibrary.clinit(NativeLibrary.java:20)

        at com.myscript.iink.NativeLibrary.<clinit>(NativeLibrary.java:26)

        at com.myscript.iink.NativeLibrary.init(NativeLibrary.java:34)

        at com.myscript.iink.NativeFunctions.<clinit>(NativeFunctions.java:21)

        at com.myscript.iink.NativeFunctions.createEngine(Native Method)

        at com.myscript.iink.Engine.<init>(Engine.java:19)

        at com.myscript.iink.Engine.create(Engine.java:38)

====================================


Can you please help us with a solution?


Thanks,

Steve


1 Comment

Dear Steve,


thank you for contacting us.


Currently, I tried creating an Android Virtual device on Nougat 7.0 x86_64, and our samples worked out of the box.


Normally, unwind is by default in the toolchain: https://github.com/urho3d/android-ndk/blob/master/toolchains/x86-4.9/prebuilt/linux-x86_64/lib/gcc/i686-linux-android/4.9.x/include/unwind.h


Can you please check your toolchain, or try using another one?


Best regards,


Olivier

Login or Signup to post a comment