Interactive Ink

Answered

Converted symbols in small editor windows are being rendered in a tiny font

Hi,


We have 4 small editors (see screenshot) which are sized to the bounds of their parent. The problem is that when the text conversion takes place, the resultant text is tiny compared to the size of the drawing (see screenshot - you may have to look closely because the text is microscopic). This seems to be a bug in the SDK because on larger editor views the text converts to something close to the size drawn, even if it's almost the full height of the view.

Our workaround was to make the editor far bigger than it's parent, and hence the text conversion is of readable size. However, this has created the problem of being able to draw outside the bounds of the parent view, and hence the text conversion is also outside the bounds of the parent. This isn't ideal.

Is there a way to prevent this issue, or define the size of what the text should resize to (note we've seen text has a font size in the iOS Styling Guide but we're in Math mode and math doesn't have a font size attribute)? Any help on this issue would be much appreciated.


Thanks,

Mark

image


image




Best Answer

Dear Mark,


thank you for contacting us and your question.


Currently, can you please try setting all the margins to 0. This is likely to solve the behavior you are facing.


Let us know if this works.


Best regards,


Olivier


Dear Mark,


currently, you should set both the horizontalMarginMM AND verticalMarginMM of the EditorViewController to zero. This should update the margins of the configuration.


Best regards,


Olivier

Sorry if double-posting but this wasn't visible the day after I posted it.

Thanks Olivier. We're not sure exactly what you're asking us to try here. The margins on our native editor views were all 0 already. We can't find any margin properties to set in the iOS Styling guide for MyScript Interactive Ink. Can you clarify what you're suggesting if it's not one of the above please?

Mark

Answer

Dear Mark,


thank you for contacting us and your question.


Currently, can you please try setting all the margins to 0. This is likely to solve the behavior you are facing.


Let us know if this works.


Best regards,


Olivier