General questions

Update the version number of the app using CocoaPods. Failed to upgrade the application from 1.3.2 to 1.4.1

Hello, I'm using CocoaPods to update the version number of my app. Upgrade the app from version 1.3.2 to version 1.4.1 .

//CocoaPods sends an error message

===================================================

[!] CocoaPods could not find compatible versions for pod "MyScriptInteractiveInk-Runtime":

 In Podfile:

 MyScriptInteractiveInk-UIReferenceImplementation (from `.`) was resolved to 1.4.1, which depends on

 MyScriptInteractiveInk-Runtime (= 1.4.1)


None of your spec sources contain a spec satisfying the dependency: `MyScriptInteractiveInk-Runtime (= 1.4.1)`.


You have either:

 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.

 * mistyped the name or version.

 * not added the source repo that hosts the Podspec to your Podfile.

===================================================

Hello, I would like to ask if I haven't cleaned it up or something else needs to be done.


 Dear Zhang Lizhi,


thank you for contacting us.

I just proceeded this way, and it worked out of the box:

  • Go to the root directory (resp. /Users/testmac/Desktop/interactive-ink-examples-ios/)
  • git pull origin master
  • git checkout 1.4.1
  • cd Examples/GetStarted

testmac@LAP-00829 GetStarted % pod install
Analyzing dependencies
Downloading dependencies
Installing MyScriptInteractiveInk-Runtime 1.4.1 (was 1.3.2 and source changed to `https://cdn.cocoapods.org/` from `trunk`)
Installing MyScriptInteractiveInk-UIReferenceImplementation 1.4.1 (was 1.3.2)
Generating Pods project
Integrating client project
Pod installation complete! There is 1 dependency from the Podfile and 2 total pods installed.

As you can see, update went fine this way.

Can you please proceed this way and confirm it works?

Best regards,

Olivier


1 person likes this

Hi olivier, my project is to use MyScriptInteractiveInk - UIReferenceImplementation.podspec file, install 1.3.2 version by pod install. Now I want to update to 1.4.1. And project has replaced IInkUIReferenceImplementation and MyScriptInteractiveInk - UIReferenceImplementation. Podspec file. Then there was a problem.

I seems to have found this problem, I use a "source" https://mirrors.tuna.tsinghua.edu.cn/git/CocoaPods/Specs.git ", to do not have this version, don't know if the influence of the problem?

Dear Zhang Lizhi,


currently, we have no experience with this mirror (nor we were aware of its existence...).


I am afraid we cannot help you more regarding the impact of the latter.


Best regards,


Olivier

Thank you for your help.  I have updated CocoaPods version number.  The version was successfully updated.