iink SDK on Device

Dose MyScript SDK support .net core?

I would like to integrated myscript sdk to Wacom's device sdk for a project. I tried to do it by intalling the MyScript.InteractiveInk.Wpf nuget package in it. However, the system crashed whem I tried to create a egine.


I don't know if it related to some certificate problem. I did followed the instruction and placing the certficate.cs like naming the identifier with the assembly name. I don't have any message at the console in Myscript.ATK.

I've tried to play around myscript sdk with the ATK sample. But when it comes to the nuget package, I failed to create a engine.

Since Wacom's sdk is using .net core, is it possible that it has no support to .net core?

Dear Samjim2013,

thank you for contacting us and your questions.

First, regarding using the .net core library, I confirm we have seen C# iink projects using it without any difficulty.

In your current case, I checked your ATK console, and saw 2 activations today. Were these with the above application? If so, shall I understand the activation is done, but at engine creation, you have the above exception when creating the engine?

Also, can you confirm you deployed all the native libraries (these shall be copied in the executable directory): MyScript.IInk.dll, MyScript2D.dll, MyScriptAnalyzer.dll, MyScriptDocument.dll, MyScriptEngine.dll, MyScriptGesture.dll, MyScriptInk.dll, MyScriptMath.dll, MyScriptPrediction.dll, MyScriptShape.dll, MyScriptText.dll and iink.dll.

If this doesn't help, please provide us with a project that allows to reproduce, so that we can investigate further. Indeed, it is difficult to provide with a more accurate answer with the above information.

Best regards,


Hi Olivier,

Thanks for your reply, that 2 activations are just from the sample program instead of my own program. So, I could not really verifiy if it is an engine issue or the certificate activation issue.

Those twelve libraries are in my project.

Heres is my project with issue. I try to create a engine in MainWindow when startup, but it failed to do so as described. Then it crashed.




Login or Signup to post a comment