iink SDK on Device

Answered

Add Interactive Ink SDK in swift project

Hello team,

  at least i want to add network communication library with  Interactive Ink SDK in swift project. can i do this coz various network communication library requires frameworks

so, will you help me in this !!

Thanks,

Shashank 


Best Answer

As Oliver stated, since 1.50 release of CocoaPods you do not need "use_frameworks" anymore. Here is an example, what you can write in your podfile: 



target '...' do 

pod 'yourWantedPod', :modular_headers => true 

pod 'MyScriptInteractiveInk-UIReferenceImplementation', :path => './.'

end

 


Dear Shashank,


Currently, since the 1.5.0 release of CocoaPods (released in April 2018), you no longer need to add the "use_frameworks" anymore:

-http://blog.cocoapods.org/CocoaPods-1.5.0/

-https://stackoverflow.com/questions/41210249/why-do-we-use-use-frameworks-in-cocoapods/41210375


Can you please ensure you are using the latest release of CocoaPods and remove the use_frameworks?


Best regards,


Olivier



Answer

As Oliver stated, since 1.50 release of CocoaPods you do not need "use_frameworks" anymore. Here is an example, what you can write in your podfile: 



target '...' do 

pod 'yourWantedPod', :modular_headers => true 

pod 'MyScriptInteractiveInk-UIReferenceImplementation', :path => './.'

end