Application Tool Kit

App Cannot Recognize Math Symbols

I have followed the steps for integrating the MAWMathWidget step by step, but am still having issues.
I keep getting an error that prints out as its description: 'Recognition thread cannot be started'. The controller will allow me to draw symbols, but it won't recognize and convert the symbols properly. Does anyone know the cause or reason behind this? I have deleted and reinstalled all the resources required, but saw no improvements. Thanks.

Thanks for your feedback and glad to see the issue has been solved now!
Best regards

Thanks a lot for the fix!
My mistake was that I didn't create a certificate with the same name as my app bundle identifier. I followed another resource for integration and never saw this documentation with that specific step before.

Thanks for your help,

Did you create a new application with the appropriate 'bundle identifier' name?
If you need more details, please check this part of our documentation:
To download any other certificate, follow this procedure:
Go to
Enter your email and password.
In the Applications tab, click Create application.
Enter your application name (at least 5 characters) and its description, then click Create.
Click Open, then Create certificate.
Enter the bundle identifier that can be found in your project's properties (General tab) and select the target environment, then click Create.
Click on the download icon to download the corresponding *.h certificate.
Paste it in your project and start creating your app.

Best regards

Hi Cate,

Thanks for responding. I did download the appropriate certificate in the link you specified. I used that certificate in the sample Xcode project I received from the SDK, and it worked fine. However, when I create a new Xcode project and use that same certificate, it doesn't work for some reason and throws the error that it can't recognize the recognition thread.


This is the error message that appears if you don't use an appropriate certificate. Did you download it on our ATK server Did you replace the default certificate.h in your XCode project?
Best regards,

Login or Signup to post a comment