General questions

Invalid certificate issue while integrating with new project

Im using xcode and i want to use my scripts iOS SDK to build an iPad app. I tried running the sample projects on the device, and everything works ok.

Now, i have started a new project and added the my script iOS sdk successfully into the project. I also created a new certificate from the my script profile and included the MyCertificate.h and this certificate (named as MyCertificate.c) into the project.The certificates bundle id matches the bundle id of my xcode project, but when i try and run the app i get an invalid certificate error because the certificate could not be registered. What am i doing wrong here?

Thanks for your message.
From the log console available in your ATK dashboard, you should be able to see an error log:
Mismatch between certificate and application: com.neemo.myscripttest != com.neemo.-
It seems to be the reason why the certificate cannot be registered properly. Could you please check again the 'bundleIdentifier' of your project? Did you enable internet connection on your device?
Best regards

I'm facing the same issue when I started to create a new certificate while creating a new project. And I already checked my bundle identifier name, same as the certificate bundle identifier name, my internet connection is on too. And still seeing invalid certificate, what went wrong?

Thanks for your error report.
When you create your own application, you need to download the appropriate certificate from your ATK dashboard and use it in your application.
On Android, change the manifest of your app and the package name of your 'Certificate' file
On iOS, when you create your own application, please make sure the bundle identifier is not something like: com.test.test.myapplicaton instead of com.test.test (automatically added at the creation of the app).
Copy your certificate file into your project, don't forget to add a certificate.h file as well. Other users reported us trouble when the bundle resources are not properly copied into the project. Could you please check again these points?

Best regards

I've checked my bundle identifier name, the bundle identifier name that I created is this:

And the created application name is: MELS Maths Script

my product name in my Xcode program is: MELS-MathsScript

I've copied the certificate file that I've created, rename it to MyCertificate.c and put it into my project, and also copied
MyCertificate.h from the downloaded sample folder and put into my project.

And I've also added the bundle resources into my project by following the guides at here:

But I'm still facing invalid certificate. I've followed what you replied, anything that I did still went wrong? Please advise, thanks.

This is still a problem for me. My Bundle identifier on xcode is com.neemo.myscript and thats what i have input in the applications section in my script. I still get an invalid certificate error.

My project name is MyScriptTest though, does this matter?

We have done some tests to figure out what happens with your projects, however we have not reproduced the problem on our side. Firstly, the name of the application in XCode does not matter.
Regarding the console log, the mismatch between bundle identifier and certificate name error does not appear anymore, so it should be something else:
- If you already had the previous ATK version (1.3), you can't mix version, so please make sure to use libs and framework from ATK 2 package only.
- When you copy the certificate into your project, could you please make sure that the checkbox to 'Add to targets' of your application is checked.

Could you please let us know what is the error message you get in the XCode log console?

Finally, if you are still stuck, could you please provide us with a part of your project in order to troubleshoot?

Best regards

I'm facing the same problem.

I tried the tutorial several times, but still can't load valid certificate. (download certificate, renamed as "MyCertificate.c", paste in my project, check the checkbox to 'Add to target', check good internet, etc)

My App name is "TestApp" and the bundle ID is "com.widevantage.test.TestApp" that same as my bundle identifier of my project.

I did all tutorial above, but when i build and execute the app the popup "Invalid certificate. Please use a valid certificate." shows.

Could you check my application? In my console, It shows nothing.

Thanks for all those details, I don't see anything wrong regarding your certificate. 

Could you please make sure you have enabled the check box  'Add to targets'  when copying the certificate in your XCode project? Did you copy languages resources as well in your project the same way?

Don't hesitate to provide us with more details, at least screenshots of your project for further investigation.

Best regards

I'm getting the same issue.  When I'm in Xcode, I can run it in the iOS simulators, but when I try to run it on my phone, I get this error 


and it crashes after I touch it.  But when I get the error on my phone, this also shows up in my Xcode project


Why is this?  I downloaded the correct certificate (I think) and I replaced the one in the samples folder.  I also have internet connection when I'm running it, but I still get the error.  What am I doing wrong?

In your case, it seems you have renamed the bundle identifier of the Diagram Widget Sample in Xcode, so there is a mismatch between the actual and expected values, as shown in the ATK server console:

"Mismatch between certificate and application: com\.myscript\..+ != MyScriptDiagram"

Do you want to run the sample or do you try to integrate the widget in your app? In the second case, you will have to create a certificate in the ATK Console with the appropriate 'bundle identifier' value.

Best regards

We have noticed on our side that the same error may occur if the MathView is 'nill' in your Xcode project, so please check as mentioned in our documentation that the MathView exists in your StoryBoard and has the 'reference outlet' to the View Controller, please visit Apple Developer website for more details:


Best regards

The instructions given here are very difficult to understand. Can somebody please give me an example of the name conventions on Android.

Dear Sir,

To start easily, we invite you to follow each steps thanks to this video:

If you have any issue, please provide us with more details so we can better help you.

Best regards

Login or Signup to post a comment