Math

Invalid certificate

I’m facing invalid certificate issue when I started to create a new certificate for my new project. And I already checked my bundle identifier name, same as the certificate bundle identifier name, my internet connection is on too. And still seeing invalid certificate, anyone know what went wrong? Thanks.


1 person has this question

Thanks for your error report.
When you create your own application, you need to download the appropriate certificate from your ATK dashboard and use it in your application.
On Android, change the manifest of your app and the package name of your ‘Certificate’ file
accordingly.
On iOS, when you create your own application, please make sure the bundle identifier is not something like: com.test.test.myapplicaton instead of com.test.test (automatically added at the creation of the app).
Copy your certificate file into your project, don’t forget to add a certificate.h file as well. Other users reported us trouble when the bundle resources are not properly copied into the project. Could you please check again these points?

I'm using IOS version, I’ve checked my bundle identifier name, the bundle identifier name that I created is this: com.e-learn-dot.MELS-MathsScript

And the created application name is: MELS Maths Script

my product name in my Xcode program is: MELS-MathsScript

I’ve copied the certificate file that I’ve created, rename it to MyCertificate.c and put it into my project, and also copied MyCertificate.h from the downloaded sample folder and put into my project.

And I’ve also added the bundle resources into my project by following the guides at here:
http://doc.myscript.com/MyScriptATK/iOS/math/maw.html

But I’m still facing invalid certificate. I’ve followed what you replied, anything that I did still went wrong? I also already clean build project and rebuild the project, still the same. Please advise, thanks.

We have done some tests to figure out what happens with your projects, however we have not reproduced the problem on our side. Firstly, the name of the application in XCode or certificate file (.c) do not matter.
Regarding the console log, the mismatch between bundle identifier and certificate name error does not appear anymore, so it should be something else:
– If you already had the previous ATK version (1.3), you can’t mix version, so please make sure to use libs and framework from ATK 2 package only.
– When you copy the certificate into your project, could you please make sure that the checkbox to ‘Add to targets’ of your application is checked.
Could you please also let us know if you tried to disable some certificates? If you disable and enable again the certificate, you may need to wait a couple of minutes to download the certificate from our servers properly (please check Internet connection as well!)

Could you please let us know what is the error message you get in the XCode log console?

Finally, if you are still stuck, could you please provide us with a part of your project in order to troubleshoot?

Best regards

Login or Signup to post a comment