Interactive Ink

INVALID_CERTIFICATE: error: AddResource

Hi

I develop with iink SDK for Android.


SOMETIMES the following error occurs.

--

Failed to edit block "MainBlock"INVALID_CERTIFICATE: error: AddResource mul/mul-lk-english_secondary_2.res failed

error: failed to read configuration script

script exits with 2 errors

--


I have created multiple EditorViews on top of the main view.

When I call the following code more than once, an error occasionally occurs.

--

contentPackage = engine.createPackage(file);

contentPart = contentPackage.createPart("Text");

editorView.getEditor().setPart(contentPart);

--


Why does this error occur?


Dear Sir,

in your console I see you have the Mismatch between certificate and application: com\.myscript error.

Can you confirm it is solved? If no, you can find topics that explain how to solved it.

Best regards,

Olivier

Thank you for your reply.

 

There is no problem with the certificate.

There is no error message on the console.

 

Sometimes I can use the iink SDK without problems.

However, SOMETIMES the following error occurs:

 

--

Failed to edit block "MainBlock"INVALID_CERTIFICATE: error: AddResource mul/mul-lk-english_secondary_2.res failed

error: failed to read configuration script

script exits with 2 errors

--

 

Apparently, I seem to happen when I call the following processing in succession.

 

--

editorView.getEditor (). setPart (contentPart);

--

 

Is there any way to solve it?

 


Dear Sir,

can you please check the mul-lk-english_secondary_2.res is present in the assets of your project?

Also, which language are you setting?

Best regards,

Olivier

Thank you for your reply.

mul-lk-english_secondary_2.res is present in the assets of my project.

 

I am setting ja_JP.

--

conf.setString("lang", "ja_JP");

--

 

Errors change from time to time. (Not the same each time)

 

--

Failed to edit block "MainBlock" INVALID_CERTIFICATE: error: AddResource ja_JP / en_JP-lk-text.res failed

--

 

OR

 

--

Failed to edit block "MainBlock" INVALID_CERTIFICATE: error: AddResource mul / mul-lk-english_secondary_2.res failed

--

etc

 

 

Sometimes it works normally.

I do not know why the error occasionally occurs.

 

 

Is there any way to solve it?

 

Thank you and best regards,

Dear Sir,

can you please check the mul/mul-lk-english_secondary_2.res resource is properly added deployed into your APK?

Best regards,

Olivier
Login or Signup to post a comment