Application Tool Kit

Linker Error in GetStartedSwift example - Unable to Build

I'm trying to build the Get Started example from GitHub, and keep getting linker errors. I have placed my certificate in the correct location and have run "pod install" to download the dependencies.

I'm using Xcode 9.2 and macOS 10.13.2. The error I get is pasted below:

Ld build/Debug-iphoneos/ normal arm64

    cd "/Users/Matt/Documents/XCode Projects/interactive-ink-examples-ios/Examples/GetStartedSwift"


    export PATH="/Applications/"

    /Applications/ -arch arm64 -isysroot /Applications/ -L/Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/Debug-iphoneos -L/Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/Pods/MyScriptInteractiveInk-Runtime -L/Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/Debug-iphoneos/MyScriptInteractiveInk-UIReferenceImplementation -L/Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/Pods/MyScriptInteractiveInk-Runtime -F/Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/Debug-iphoneos -filelist /Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/ -Xlinker -rpath -Xlinker @executable_path/Frameworks -miphoneos-version-min=9.1 -dead_strip -Xlinker -object_path_lto -Xlinker /Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/ -Xlinker -export_dynamic -Xlinker -no_deduplicate -fobjc-link-runtime -L/Applications/ -Xlinker -add_ast_path -Xlinker /Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/ -ObjC -Wl,-u,_MyScript2D -Wl,-u,_MyScriptAnalyzer -Wl,-u,_MyScriptDocument -Wl,-u,_MyScriptEngine -Wl,-u,_MyScriptGesture -Wl,-u,_MyScriptInk -Wl,-u,_MyScriptMath -Wl,-u,_MyScriptPrediction -Wl,-u,_MyScriptShape -Wl,-u,_MyScriptText -lMyScript2D -lMyScriptAnalyzer -lMyScriptDocument -lMyScriptEngine -lMyScriptGesture -lMyScriptInk -lMyScriptInteractiveInk-UIReferenceImplementation -lMyScriptMath -lMyScriptPrediction -lMyScriptShape -lMyScriptText -lc++ -liink -framework Foundation -framework Security -framework SystemConfiguration -lPods-GetStartedSwift -Xlinker -dependency_info -Xlinker /Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/ -o /Users/Matt/Documents/XCode\ Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/Debug-iphoneos/

ld: warning: directory not found for option '-L/Users/Matt/Documents/XCode Projects/interactive-ink-examples-ios/Examples/GetStartedSwift/build/Debug-iphoneos/MyScriptInteractiveInk-UIReferenceImplementation'

ld: library not found for -lMyScriptInteractiveInk-UIReferenceImplementation

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Any help would be greatly appreciated!

Dear Matt,

Currently, your porject is not finding UIRefImpl. Are you using the workspace, as indicated in the documentation? Indeed, the workspace does the link in between GetStartedSwift and UIRefImpl, and it is likely UIRefImpl is not built, thus your project cannot link.

Best regards,


Hi Oliver, I am following the instructions from the documentation that appeared when I received my iOS certificate. I have also searched for other documentation on the website to find if there are any additional steps.

Basically I have the three projects from the GitHub repository (GetStarted, GetStartedSwift and Demo), have installed the CocoaPods in each one and put my certificate in the correct location for each one as well. I'd prefer to work with Swift so that is the main project I've been trying to compile, but I have also tried the others and get the same result.

I believe you that the reference implementation has not been built - however how do I get this to build? I have a directory that appears to contain the code for the reference implementation - it is called IInkReferenceImplementation, and it contains subfolders for Assets and Classes. There is no Xcode project in there however for me to build.

I'm not sure what I need to do in order to get the GetStartedSwift project to pick up these source code files and compile them. I'm not that strong with Xcode.

Dear Matt,

On our side we reproduce the issue if we just opened and build `GetStartedSwift.xcodeproj` instead of `GetStartedSwift.xcworkspace`, so could you please check again?

- download the project from git and open 'GetStartedSwift.xcworkspace' workspace to build

If you still face problem, could you please add screenshots and give us more details, such as XCode version, so we can investigate further?

Best regards

How embarrassing... I didn't even know what a workspace was until now. I'm really new to Xcode. I guess it's equivalent to a solution in Visual Studio...

Sorry for wasting your time.

Merry Christmas.