iink SDK on Device

iOS Integration error

I have downloaded code from Git with

git clone https://github.com/myscript/interactive-ink-examples-io

Now i am trying to run Swift Example and tried to run command pod install

I am getting this error 


Analyzing dependencies

Fetching podspec for `MyScriptInteractiveInk-UIReferenceImplementation` from `../..`

[!] CocoaPods could not find compatible versions for pod "MyScriptInteractiveInk-Runtime":

 In snapshot (Podfile.lock):

 MyScriptInteractiveInk-Runtime (= 1.1.2)


 In Podfile:

 MyScriptInteractiveInk-UIReferenceImplementation (from `../..`) was resolved to 1.1.2, which depends on

 MyScriptInteractiveInk-Runtime (~> 1.1.2)


None of your spec sources contain a spec satisfying the dependencies: `MyScriptInteractiveInk-Runtime (= 1.1.2), MyScriptInteractiveInk-Runtime (~> 1.1.2)`.


You have either:

 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.

 * mistyped the name or version.

 * not added the source repo that hosts the Podspec to your Podfile.

 


Dear Nicholas,


thank you for the update, we are glad it is working.


Best regards,


Olivier

Never mind. I got the solution. Something wrong with ruby. Removed ruby and cocoapods and installed again. And it worked. 

Thank you for your time.

I tried with

pod install --repo-update

Updating local specs repositories

[!] Failed to connect to GitHub to update the CocoaPods/Specs specs repo - Please check if you are offline, or that GitHub is down


I tried with verbose so you might get what is happening 

pod install --repo-update --verbose

 Preparing


Updating local specs repositories


Updating spec repo `master`

[!] Failed to connect to GitHub to update the CocoaPods/Specs specs repo - Please check if you are offline, or that GitHub is down


/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-1.4.0/lib/cocoapods-core/github.rb:105:in `rescue in modified_since_commit'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-1.4.0/lib/cocoapods-core/github.rb:100:in `modified_since_commit'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-1.4.0/lib/cocoapods-core/source.rb:445:in `unchanged_github_repo?'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-1.4.0/lib/cocoapods-core/source.rb:334:in `update'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/sources_manager.rb:88:in `block (2 levels) in update'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/user_interface.rb:64:in `section'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/sources_manager.rb:87:in `block in update'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/sources_manager.rb:86:in `each'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/sources_manager.rb:86:in `update'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/installer/analyzer.rb:247:in `block in update_repositories'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/installer/analyzer.rb:245:in `each'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/installer/analyzer.rb:245:in `update_repositories'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/installer.rb:150:in `block in resolve_dependencies'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/user_interface.rb:64:in `section'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/installer.rb:149:in `resolve_dependencies'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/installer.rb:116:in `install!'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/command/install.rb:41:in `run'

/Library/Ruby/Gems/2.0.0/gems/claide-1.0.2/lib/claide/command.rb:334:in `run'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/lib/cocoapods/command.rb:52:in `run'

/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.4.0/bin/pod:55:in `<top (required)>'

/usr/local/bin/pod:23:in `load'

/usr/local/bin/pod:23:in `<main>'




Dear Nicholas,


Thank you for contacting us.


can you please do pod install --repo-update?


Let us know if this doesn't work.


Best regards,


Olivier