Interactive Ink

GetStarted Build Failed

Hello,

I am a new developer and wanted to implement offline handwriting recognition to my app.

For this I wanted to get in touch with the MyScript API following this documentation: https://developer.myscript.com/docs/interactive-ink/1.3/ios/fundamentals/get-started/

I performed all steps as described but when I hit run on xCode (xCode 10.1, MacOS 10.14.2) I gives out two compiling errors:

1) module map file 'build/Release-iphoneos/MyScriptInteractiveInk-Runtime/MyScriptInteractiveInk_Runtime.modulemap' not found

2) missing required module 'SwiftShims'

How can I fix this issue?

Please describe it detailed because I am very new in the developing scene of ios (java guy)


Dear Marc,


thank you for contacting us.


Currently, ensure the following:

-"pod install" worked fine, without any error

-Delete the DerivedData directory: rm -rf /Users/LOGIN/Library/Developer/Xcode/DerivedData/ (replace LOGIN by your own one)

-Open the "GetStartedSwift.xcworkspace" file (DO NOT open the GetStartedSwift.xcodeproj)

-Clean your project(Product -> Clean Build Folder)

-Run your project


=>It should now work properly.


Let us know if this helps.


Best regards,


Olivier

Hello Oliver, thanks for your quick reply. I have done the steps as described but it does not work ;( Following errors artive when build fails: module map file '/Users/Marc/Library/Developer/Xcode/DerivedData/GetStartedSwift-alyzolhiotvjyvgkepngxxcqwkvo/Build/Products/Debug-iphonesimulator/MyScriptInteractiveInk-Runtime/MyScriptInteractiveInk_Runtime.modulemap failed to emit precompiled header '/Users/Marc/Library/Developer/Xcode/DerivedData/GetStartedSwift-alyzolhiotvjyvgkepngxxcqwkvo/Build/Intermediates.noindex/PrecompiledHeaders/GetStartedSwift-Bridging-Header-swift_J994WVMUQEY2-clang_NNP3M73WA7IQ.pch' for bridging header '/Users/Marc/Downloads/interactive-ink-examples-ios-master/Examples/GetStartedSwift/GetStartedSwift/Supporting Files/GetStartedSwift-Bridging-Header.h' What do you mean with open the xcodeproject (Do not open it)? I hope we can get it running Best regards, Marc

Dear Marc,


My apologies, I just updated my answer, as I should have written DO NOT open the GetStartedSwift.xcodeproj


Following the above and opening the "GetStartedSwift.xcworkspace" file under xcode, it should work.


Best regards,


Olivier

Dear Oliver, thanks for your help. Now it works. Best regards Marc
Login or Signup to post a comment