Text

Import and Export

Hi Olivier,

I am using a custom set of words. 

However while Importing I end up importing a word that is not present in my custom list.

I am able to see the word while displaying the input. 

Though when I am exporting the data, the text is coming as null.

Is there a way to over come this?

Regards,

Piyush


Dear Piyush,


thank you for contacting us.


Currently, I tried to reproduce on my side, with a simple lexicon containing 4 words. I did not attach any other LK to my configuration, which you can find:

Name: customLex
Type: text
Configuration-Script:
AddResource en_US/en_US-ak-cur.res
AddResource en_US/myLex.res
EnableAlienCharacters
SetTextListSize 1
SetWordListSize 5
 SetCharListSize 1


With this configuration, I am able to import a word that doesn't belong to the "myLex.res" lexicon in my editor, and it gets displayed.

Nevertheless, if I try to add anything else (e.g. word, letter...), then I have a "no result", which is the expected behavior as a lexicon by itself only allows a single word.


To go around this:

-Either you add a GRM to your configuration, which will allow you to "loop" over your lexicon

-Or you add the lk-text resource.


If this doesn't work, can you please provide with your exact scenario, configuration...


Best regards,


Olivier

Hi Olivier,

The import is working fine. 

The issue that I have is when I try to export the data (that has just been imported) which is not there in my custom lexicon, the export does not work.

I am not trying to transcribe again, this is data that has been imported.

The limitation that I have is that i cannot add the lk-text resource, because then my transcription goes for a toss.

Do let me know if there is some way of achieving this.

Regards,

Piyush


Dear Piyush,


can you confirm you call the "waitForIdle" before export?


Also, when setting a breakpoint in debug mode, do you see the exported string in the debug variables? Maybe it is a display issue?


Best regards,


Olivier

Dear Olivier,

yeah, we actually wait before re exporting the data.

while re-exporting, since the imported word  (even though it has already been transcribed and shows in the normal letters ) is not there in the lexicon, while exporting the data is blank.

As you mentioned one solution would be to use lk-text, but unfortunately we cannot use that because otherwise our transcription will go for a toss.

Is there any other way that you can suggest or this is not possible?

Piyush