iink SDK on Device

Problem with custom lexicon

Hey support team,

we have an issue with some words not begin recognized by word processor. For example word characteful is recognized as character ful (with space in between).

I've found in documentation that the thing I may want is custom lexicon.

The lexicon file I prepared looks like this:

fingerwork Fingerwork characterful Characterful accompanimental Accompanimental

I generated the res file using online tool: https://developer.myscript.com/support/recognition-assets, copied it to resources folder and added to configuration like attached.

Unfortunately after trying to type something I've received an error like in attached screenshoot. (IO_FAILURE: error: AddResource en_US/lex.res failed error: failed to read configuration script script exits with 2 errors).

Next I tried generating lexicon inside the app. I've generated res file and put it in correct folder. The error stopped occurring but the recognition is still not working correctly.

Before we were using library version1.3 but now I've updated it to latest 1.4.1. Unfortunately on both it's not working.

Could you please help solve the issue?

conf
(311 Bytes)

Thanks for your response.

I've read https://developer-support.myscript.com/support/discussions/topics/16000026397 and in our case it is number 3.

I've generated a new res file Subset Knowledge (Text) and added it to folder instead of previous lexicon. The config remained unchanged.

Unfortunately the new words are still not working. Do you have an idea what may be wrong?

By the way the is iOS.

Hello Julie,



If your scenario is number 3, you should generate a new res Lexicon (Text) file with the resource builder tool

One further point you should check, is that in you have a word per line in your input .txt file from which you generate your .res file.


For instance I tested attached .txt file to try to match your use case. Then I generated the attached .lex.res chosing the res Lexicon (Text) file option and conf below:


Bundle-Version: 1.0
Bundle-Name: en_US
Configuration-Script:
 AddResDir ../resources/

Name: text
Type: Text
Configuration-Script:
 AddResource en_US/en_US-ak-cur.res
 AddResource en_US/en_US-lk-text.res
 AddResource en_US/lex.res
 EnableAlienCharacters
 SetTextListSize 1
 SetWordListSize 5
 SetCharListSize 1



Could, you please, give a try with the attached lex.txt file and let me know if this fixes your issue?


Thanks.


Gwenaëlle

txt
(84 Bytes)
Login or Signup to post a comment