Cloud Development Kit

Internal error is shown.

Currently, sometimes the below error is happened.

What mean this error "internal error"?
Also, how can we avoid it?


image



Hi Masashi,

Many reasons could explain an internal error. It could be an error on our side, some type of unexpected content or coding errors on your side. Could you provide us a little bit more details. WHat kind of content did you set up? What is the API version? What did you write?

We are waiting your answer

Regards

Pierre-Alban DEWITTE - Head of cloud @MyScript

Thank you so much for your reply.
And sorry for few information.

We are using  CDK ver4.0.0.

Also , we follow the manual in the below site.

https://github.com/MyScript/myscript-math-web


Besides, this issue happen when we load this module.

So, we write nothing.


Best regards.

Masashi Takahashi.

Hi Masashi,

We need further details as we do no reproduce the issue when following instructions on the github page.

What is your browser? What version? Do you use the web component in a regular html page or along with a framework like React, Angular, VueJS or any other?

If your corporate rules allows it, could you share the code?

Best regards

Pierre-Alban DEWITTE - head of cloud @MyScript

Dear Pierre


Thank you so much for your reply.

I answer as the below.

> What is your browser? What version? 

We use Chrome Ver 64.0.3282.167 (64bit).


> Do you use the web component in a regular html page or along with a framework like React, Angular, VueJS or any other?

We use this library in a regular html page, not framework.


> If your corporate rules allows it, could you share the code?

The below is a source code in a embedded source code.

(The key is hided, but we set the key which is activated.)


<myscript-math-web id="math-input" applicationkey="my applicationkey" hmackey="my hmackey" hideexportzone="" disablecontrols="" touch-action="none" protocol="WEBSOCKET" scheme="https" host="cloud.myscript.com" apiversion="V4" triggerdelay="2000" processdelay="1000" timeout="2000" themecolor="#1580CD" themewidth="1" solvercolor="#A8A8A8" fontfamily="STIXGeneral" initialized="">

</myscript-math-web>


Dear Masashi,

Could you try to refresh your bower dependencies (by removing bower_components directory and launch a bower install in the directory where you place the bower.json file) ?

You will also have to remove the "initialized" attribute and if you are in a slow network you should increase the "timeout" value to 5000.

I successfully run an example with this markup and a fresh bower install

 

<myscript-math-web id="math-input" applicationkey="SECRET" hmackey="SECRET" hideexportzone="" disablecontrols="" touch-action="none" protocol="WEBSOCKET" scheme="https" host="cloud.myscript.com" apiversion="V4" triggerdelay="2000" processdelay="1000" timeout="5000" themecolor="#1580CD" themewidth="1" solvercolor="#A8A8A8" fontfamily="STIXGeneral"></myscript-math-web>

 Best regards

Pierre-Alban - head of cloud @MyScript

Dear Pierre

Thank you so much for your answer.
I try it.


Best regards.

Masashi Takahashi.

Login or Signup to post a comment