General questions

Answered

swagger script API keeps returning access.not.granted (error code 401)

 I tired looking at the link https://developer-support.myscript.com/support/discussions/topics/16000027079 and followed all the steps.

But i could not find "Enable Hmac " as mentioned in the first step on my dashboard,


"First, ensure the "Enable Hmac" check box is ticked in the Cloud dashboard of your application"


can you please help me with the same.





Best Answer

Dear Malu,

thank you for contacting us.

In order to disable the hmac, you shall login to your dashboard: cloud.myscript.com
After login, go to the "Applications" tab
Open the application you are using
go to the bottom of the page
You will then have your "Application key", "Enable HMAC" and the "HMAC Key"
Uncheck the "Enable HMAC"
You shall then be able to run request without computing the HMAC key.

Best regards,

Olivier

1 Comment

Answer

Dear Malu,

thank you for contacting us.

In order to disable the hmac, you shall login to your dashboard: cloud.myscript.com
After login, go to the "Applications" tab
Open the application you are using
go to the bottom of the page
You will then have your "Application key", "Enable HMAC" and the "HMAC Key"
Uncheck the "Enable HMAC"
You shall then be able to run request without computing the HMAC key.

Best regards,

Olivier